Note: This document started out as an e-mail reply to a question from a friend, about how to convert macros to VBA code.

How to Convert Macros to Visual Basic for Applications Code

> And importantly, is it simple to do too?
I think it is.  Here is the official Microsoft KB article on the subject:

 

   ACC2000: How to Convert Macros to Visual Basic for Applications Code

   http://support.microsoft.com/?id=210245
 

They seem to be leaving out some critical information, such as *what* to do with the converted code after you are done.  I'll try to write up a simple set of instructions this weekend.  I'll use a macro in the Northwind database as an example, instead of using your database, so that when the next person wants to know how to do this, you or I can share the same instructions with them.

_________________________________________

 

Hi Stephen,

 

I decided to use the Northwind macro group named Customers for this conversion exercise.  This is called a macro group, because it actually contains two separate macros, which you can see if you open the macro in design mode: "ValidateID" and "Update Country List".

 

Special notes:

1. You might need to click on View > Macro Names in order to see the names listed above. 

2. The Autokeys macro cannot be converted to VBA code.  Defining autokeys is one of the only times you will ever need a macro.

One can see the following property entered for this macro group: "Attached to the Customers form. Validates that the customer ID is unique before you leave the field."  We can see from the comments column that the ValidateID macro is attached to the BeforeUpdate event of the CustomerID field, and the Update Country List macro is attached to the AfterUpdate event of the form.  So, we need to stick the code in these two event procedures when we are all done with the conversion.  Before converting a macro, it is helpful to add useful comments to the various macro action lines.

 

Step 1: Select the macro that you wish to convert without running it or opening it in design view
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Step 2:  Click on Tools > Macro > Convert Macros to Visual Basic
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Step 3: Decide whether or not to include error handling and macro comments.  As a minimum, I recommend including the comments.  However, I'm not a real fan of the wizard generated error handling code.  Click on the Convert button.
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Step 4:    You should see a message incicating success.  You're all done!

However, when you see all this code, it can be very easy to be intimidated.  This code module was opened up automatically, and does not represent the macro that we just converted.  Close this module by clicking on the X in the upper right corner.
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Step 5:    Select the Modules tab from the database window.  You should see a new module named "Converted Macro- Customers"
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Step 6:    Select this new module and open it in design view.  You should see the following code.  This code should include Option Explicit as the second line of code.  If your module does not include this line of code, then type it in manually.  There is an option that you can (and should) set in the VBA development environment to "Require Variable Declaration" in new modules, which is exactly what Option Explicit accomplishes.  This module includes two new functions: Customers_ValidateID() and Customers_Update_Country_List().
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Special notes:
1. The image shown above includes only one of the two functions. 

2. Comments are shown in green text, and are preceded with an apostrophe. 

3. Macros are always converted to functions.  However, most of the time, you will want to use the converted code in a subroutine, not a function.  A subroutine performs a task.  A function performs a task and returns a value.  That's the difference between subroutines and functions--subroutines do not return a value. 

4. Keywords such as Function, Sub, On Error GoTo, If, End If, Exit Function, Resume and End Function are shown in navy colored font as the default setting. 

5. A procedure (Function or Sub) is Public by default in a module.  However, in general, procedures in code behind forms or code behind reports is generally private to that form or report.  It is best to limit the scope of a procedure--ie. don't make it public unless you need to call it from various locations.

Notice the error handling that was added by the wizard.  It starts with the 2nd line of code shown below, and generally includes two labels: a procedure error label (named Customers_ValidateID_Err:  in this case) and a procedure exit label (named Customers_ValidateID_Exit:  in this case).  Labels always include a colon (:) after the label name; this is where control is directed to in the event of an error (On Error GoTo Customers_ValidateID_Err).  If the code runs without an error, it will encounter the exit label first, followed by the Exit Function (or Exit Sub) statement.  Thus, the code that is a part of the error label will never be executed if the code runs without an error.

        Function Customers_ValidateID()
        On Error GoTo Customers_ValidateID_Err
        

        ' Converted code is here
 

 

        Customers_ValidateID_Exit:
             Exit Function
 

        Customers_ValidateID_Err:
              MsgBox Error$
              Resume Customers_ValidateID_Exit

 

        End Function
 

I personally prefer the much more generic form, using label names of ProcError and ExitProc in all of my procedures.  I also prefer to include the error number, a colon and a space, the error description, an error type, and a string for the title of the message box, instead of the more generic MsgBox Error$ :
 

        Function Foobar()
        On Error GoTo ProcError
        

        ' Your code goes here
 

 

        ExitProc:
             Exit Function
        ProcError:
             MsgBox "Error " & Err.Number & ": " & Err.Description, vbCritical, _
                          "Error in Customers_ValidateID event procedure..."
             Resume ExitProc

        End Function
 

Note the space underscore at the end of the first line of the MsgBox statement.  This is a line continuation character, and it allows you to break up a long line of code into one or more lines of code to improve readability.  There are tools (Add-Ins) available to assist with adding error handling to your procedures.  You can generally customize the error handling that is added, such as the label names of your choice (ProcError & ExitProc, for example), and the message box statement.  This is why I generally do not include the check on the option to include the wizard generated error handling.  It does not use generic labels and is not customizable.

 

In this case, Foobar should be a subroutine, since there is no return value specified.  Examples of specifying a return value include:

 

        Function Foobar() As String          returns a string (text) value
        Function Foobar() As Long           returns a numeric long integer value
        Function Foobar() As Boolean      returns a boolean (true/false) value
 

Other common return types include Byte, Currency, Date, Double, and Integer.  If a function does not specify a return value, then it really should be a subroutine instead.  If the Foobar function is changed to a subroutine, a few lines of code will change, as indicated below:

 

        Sub Foobar()
        On Error GoTo ProcError
        

        ' Your code goes here
 

 

        ExitProc:
             Exit Sub
        ProcError:
             MsgBox "Error " & Err.Number & ": " & Err.Description, vbCritical, _
                          "Error in Customers_ValidateID event procedure..."
             Resume ExitProc

        End Sub
Step 7:    Open the Customer's form in design view.  Click on View > Properties to bring up the Properties window.  As an alternative, you can double-click the small black square that is displayed in the upper left corner of the form (shown with blue circle).  In Access 2002 and 2003, you can also use the F4 key.  Make sure that you see "Form" displayed in the blue title bar.  Select the Event tab.   Here, we notice an After Update event procedure that references Customers.Update Country List.  In other words, it is currently referencing the Update Country List macro contained within the macro group named Customers.
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Click into the After Update item.  You should see a dropdown arrow and an build button (ie. a button with three dots).  If you click on the build button, you should find yourself in macro design view.  We want to click on the dropdown arrow, and then select "Event Procedure" from the top of the list:
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Step 8:    After selecting "Event Procedure", click on the build button.  You should find that the code behind this form is now displayed.  A brand new Form_AfterUpdate() event procedure has just been created for you (you would not have found this procedure if you had clicked on View > Code prior to selecting Event Procedure and clicking on the build button).  You should see "Form" in the Object dropdown list, "AfterUpdate" in the Procedure dropdown list, and a blinking cursor in-between Private Sub Form_AfterUpdate() and End Sub: 
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Step 9:    Minimize this code window, and the form in design view, if necessary.   Select the Modules object.  Open the "Converted Macro- Customers" module.  Use the vertical scroll bar to display the converted code for the Customers_Update_Country_List code.  Select everything in-between Function Customers_Update_Country_List() and End Function, but don't include these two lines of code in your selection.  Press Ctrl + C to copy the selection to the clipboard (or Edit > Copy).

 

Click on View > Project Explorer (Ctrl + R).  Select Form_Customers and double-click on it.  With your cursor in the same position as originally indicated, paste the code from the clipboard into the Form_AfterUpdate event procedure.   Then find the line of code that reads Exit Function and change it so that it reads Exit Sub (since this is a subroutine).  You should have something that looks as follows:
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This pasted code includes the "named" error and exit procedure labels, which I'm really not too fond of seeing.  You might want to change them to the more generic ProcError and ExitProc labels, as indicated below:

 

        Private Sub Form_AfterUpdate()
        On Error GoTo ProcError
        

        ' Requery the Country control.
         DoCmd.Requery "Country"
 

        ExitProc:
             Exit Sub
        ProcError:
             MsgBox "Error " & Err.Number & ": " & Err.Description, vbCritical, _
                          "Error in Form_AfterUpdate() event procedure..."
             Resume ExitProc

        End Sub
 

Step 10:    Click on the Save toolbar button to save your changes.  Then click on Debug > Compile DatabaseName.
If all went well, your project should compile correctly without any errors.  When working with VBA code, you should get in a habit of compiling the code fairly often.  That way, you'll catch any compile errors as they occur, instead of waiting until sometime later when you might find compile errors all over the place in various code modules.
Step 11:    Close the code module.  Save the form in design view.  Test out this new AfterUpdate event procedure by making some change to the data.  For example, change Alfreds Futterkiste to Alfreds Futterkistee, and then click the record selector to move to the next record.  This will cause the Form_AfterUpdate event procedure to fire.

 

Step 12:    Repeat steps 7-10, with the following changes:

· Select the Customer ID text box on the form first, so that it's properties are displayed in the Properties window. You should see "Text Box: CustomerID" in the blue title bar. 

· In step 9, copy the converted code for the Customers_ValidateID macro to paste into a new CustomerID_BeforeUpdate event procedure.
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Step 13:    Close the code module.  Save the form in design view.  Test out this new CustomerID_BeforeUpdate event procedure by attempting to add a new record.  Use a primary key that you know already exists, such as ALFKI.  When you tab out of the Customer ID textbox, this procedure should fire, and you should receive a message box informing you that this ID already exists:
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Step 14:    Once you are satisfied that everything is working properly, delete the Customers macro and the "Converted Macro- Customers" module.   Finish it off with a compact & repair operation:  Tools > Database Utilities > Compact and Repair Database...
